Online Sim Racing netKar PRO


    NK server tool not working after update?

    Share
    avatar
    Paul Doherty
    Driver
    Driver

    Posts : 34
    Join date : 2012-09-04
    Age : 51
    Location : Sydney Australia

    NK server tool not working after update?

    Post by Paul Doherty on Sun Sep 30, 2012 12:17 pm

    Updated last night and created host with NK Server tool. After joining the host I have set up my car appears in a garage with the garage door closed (but with a pit out sign in front of me). Message comes up on right hand side "Session is closed to new clients connection refused" then a message comes up "Server is not responding exit and try again"

    Can anyone help me with this?
    avatar
    Andrea Lojelo
    ---
    ---

    Posts : 12576
    Join date : 2009-04-26
    Age : 38
    Location : Den Haag

    Re: NK server tool not working after update?

    Post by Andrea Lojelo on Sun Sep 30, 2012 12:22 pm

    Yes. that tool needs an update. I already contacted Juha about it. I'll let you know more soon. For now you can start up the server configuring it with nkservertool, press save cfg, and then run the nkserver.exe from the nk folder.

    This will allow you to run only 1 server at the time. Other option is do copy some files manually in a different folder, but it's a bit long to explain.

    I hope I can let you know something soon for an update of the tool. I'll keep you posted


    _________________
     
    avatar
    Paul Doherty
    Driver
    Driver

    Posts : 34
    Join date : 2012-09-04
    Age : 51
    Location : Sydney Australia

    Re: NK server tool not working after update?

    Post by Paul Doherty on Sun Sep 30, 2012 12:24 pm

    Thanks for your quick reply I'll try your first suggestion
    avatar
    Paul Doherty
    Driver
    Driver

    Posts : 34
    Join date : 2012-09-04
    Age : 51
    Location : Sydney Australia

    Re: NK server tool not working after update?

    Post by Paul Doherty on Sun Sep 30, 2012 12:33 pm

    Hey Andrea here is what happened. I saved the settings using the NK Server tool that was fine. I ran the NKserver.exe as you suggested from the root folder. I then started the game and went to online race. I could see 2 of my rooms in there with the track and correct name etc. When I try to join the race I get the " Server is not responding please exit and try again" error. Any suggestions?
    avatar
    Andrea Lojelo
    ---
    ---

    Posts : 12576
    Join date : 2009-04-26
    Age : 38
    Location : Den Haag

    Re: NK server tool not working after update?

    Post by Andrea Lojelo on Sun Sep 30, 2012 1:19 pm

    2 servers? wait a sec, have you clicked on "save config" or "Start server" in nkservertool? you can use nkservertool just for configuring your server (obviously you can also do it manually on the cfg file or via nk gui), and then press "save config".
    Do you have one or 2 nkservers running? check on your windows task manager if is there any other nkserver.exe running.


    _________________
     
    avatar
    Paul Doherty
    Driver
    Driver

    Posts : 34
    Join date : 2012-09-04
    Age : 51
    Location : Sydney Australia

    Re: NK server tool not working after update?

    Post by Paul Doherty on Sun Sep 30, 2012 1:57 pm

    I have selected "save config on exit" with the NK server tool so no I don't hit save etc before exit. It seems to retain my settings so that soesn't seem to be the problem. Every time I start a server using the tool (and maybe even without I can't remember) it shows me 2 versions of the game I have setup. Note when I check Task Manager it only shows 1 NK server running in applications and processes I don't know why the GUI shows me 2 versions see the screen grab www.prodealer.com.au/jhedfjce.png the race I setup is called RACE ON.
    avatar
    Andrea Lojelo
    ---
    ---

    Posts : 12576
    Join date : 2009-04-26
    Age : 38
    Location : Den Haag

    Re: NK server tool not working after update?

    Post by Andrea Lojelo on Sun Sep 30, 2012 2:04 pm

    I just see one RACE ON server online. When I get in it says that the session is closed to the new clients. it means that the server is misconfigured. can you post here your nkservercfg.ini?

    I guess you see 2 instances on the gui, if you run the server on the same pc you're playing.


    _________________
     
    avatar
    Paul Doherty
    Driver
    Driver

    Posts : 34
    Join date : 2012-09-04
    Age : 51
    Location : Sydney Australia

    Re: NK server tool not working after update?

    Post by Paul Doherty on Sun Sep 30, 2012 2:29 pm

    I hope this is the file you are talking about from the nkpro13/cfg folder

    [CONFIGURATION]
    PORT=9500
    BANDWIDTH=1000
    MODE=2
    MAXCLIENTS=15
    ACCEPTVERSION=107
    NAME=RACE ON
    TRACK=Nurburgring
    CONFIGURATION=Full GP
    CAR=FormulaKS2;
    PASSWORD=
    ADMIN=
    REGISTER=1
    MULTIPORT=0
    LOOP=1
    WINNERBALLAST=0
    FRONTTIRE=
    REARTIRE=
    FULLMODE=0
    DAMAGE=100
    RAIN=0
    SESSIONS=2

    [SESSION0]
    NAME=Session1
    TYPE=2
    ESCMODE=0
    MINLAPS=0
    MAXLAPS=0
    RACELAPS=5
    VALIDPERC=100
    SESTIME=20
    WAITTIME=30
    ACCEPTNEW=1

    [SESSION1]
    NAME=Session2
    TYPE=1
    ESCMODE=0
    MINLAPS=0
    MAXLAPS=0
    RACELAPS=15
    VALIDPERC=100
    SESTIME=15
    WAITTIME=1
    ACCEPTNEW=0

    [ENTRYLIST]
    ENTRIES=0
    USEFORGRID=0
    avatar
    Andrea Lojelo
    ---
    ---

    Posts : 12576
    Join date : 2009-04-26
    Age : 38
    Location : Den Haag

    Re: NK server tool not working after update?

    Post by Andrea Lojelo on Sun Sep 30, 2012 3:02 pm

    try to modify:
    ACCEPTVERSION=113
    and I would use ACCEPTNEW=1 even in the racing session otherwise you will not be able to enter if the server is in racing mode.


    _________________
     
    avatar
    Paul Doherty
    Driver
    Driver

    Posts : 34
    Join date : 2012-09-04
    Age : 51
    Location : Sydney Australia

    Re: NK server tool not working after update?

    Post by Paul Doherty on Sun Sep 30, 2012 3:12 pm

    Thanks I will try to make the changes you have suggested and will test (not until tomorrow now) - The strange thing is if you look at what is on the NK Server tool screen it says "Accept Version 1.0.3" but in the box next to it (maybe it's the end of the range setting) It says in grey 1.07. I see the above config file is recording at as accept version 1.07
    avatar
    Paul Doherty
    Driver
    Driver

    Posts : 34
    Join date : 2012-09-04
    Age : 51
    Location : Sydney Australia

    Re: NK server tool not working after update?

    Post by Paul Doherty on Sun Sep 30, 2012 3:33 pm

    I just did a quick test and it seemed to fix it. I edited te files then ran the NKserver.exe manually instead of using the tool. Thanks for your help on this one I've learnt now I can just manually edit that file then run the nkserver.exe - That's a great help thanks again:)
    avatar
    Andrea Lojelo
    ---
    ---

    Posts : 12576
    Join date : 2009-04-26
    Age : 38
    Location : Den Haag

    Re: NK server tool not working after update?

    Post by Andrea Lojelo on Sun Sep 30, 2012 3:50 pm

    on the nkservertool you can also select other and specify the version in the text box. good suggestion for the next release of nkservertool.

    I'm glad that fixed the issue for you.


    _________________
     
    avatar
    Paul Doherty
    Driver
    Driver

    Posts : 34
    Join date : 2012-09-04
    Age : 51
    Location : Sydney Australia

    Re: NK server tool not working after update?

    Post by Paul Doherty on Sun Sep 30, 2012 4:09 pm

    Thanks much appreciated

    Wally Masterson
    Driver
    Driver

    Posts : 47
    Join date : 2011-03-11

    Re: NK server tool not working after update?

    Post by Wally Masterson on Mon Oct 01, 2012 8:49 am

    I have a theory (untested), that if you add your nkpro folder (e.g. C:\nkpro13) to your system path variable on the PC running your server, the server tool will work. This might mean that the server the tool creates will be able to find the two new msvc100 dll files without the server tool having to copy them to your new server folder.

    In Windows 7, search your control panel for "View advanced system settings". Click on the "Environment variables" button. In the "system variables" section, find the "Path" variable and edit it. Add ";C:\nkpro13" (with the semicolon and without the double quotes) to the end of your path variable and click OK.

    I'd be interested to hear if that works.
    avatar
    Paul Doherty
    Driver
    Driver

    Posts : 34
    Join date : 2012-09-04
    Age : 51
    Location : Sydney Australia

    Re: NK server tool not working after update?

    Post by Paul Doherty on Mon Oct 01, 2012 10:23 am

    Hey Wally I'll check it out and let you know. Cant do it now got friends over for the evening. Hopefully see you online tomorrow night but still terrible in the F1800
    avatar
    Paul Doherty
    Driver
    Driver

    Posts : 34
    Join date : 2012-09-04
    Age : 51
    Location : Sydney Australia

    Re: NK server tool not working after update?

    Post by Paul Doherty on Tue Oct 02, 2012 2:52 am

    Never tried anything like this before but it seemed to work. I went to where you said and added an entry for nkpro13 - Went to the server tool started host. Opened the game joined the host and car was in the pit no issues. Didn't test drive (leave from pit because wheel etc wasn't setup). Only thing I'm not sure on is if it worked because I had already manually edited the file (see thread above) or because I made those changes in Control Panel.


    Last edited by Paul Doherty on Tue Oct 02, 2012 2:53 am; edited 1 time in total (Reason for editing : typo)
    avatar
    Leonardo Ratafia
    Driver
    Driver

    Posts : 244
    Join date : 2010-04-18
    Age : 39
    Location : Montevideo - Uruguay

    Re: NK server tool not working after update?

    Post by Leonardo Ratafia on Tue Oct 02, 2012 4:34 pm

    yes, it doesn´t make the error anymore, but it think you still would need to copy the cars folder into the server structure as Andrea posted some time ago.
    when they were testing the patch
    avatar
    Andrea Lojelo
    ---
    ---

    Posts : 12576
    Join date : 2009-04-26
    Age : 38
    Location : Den Haag

    Re: NK server tool not working after update?

    Post by Andrea Lojelo on Tue Oct 02, 2012 5:09 pm

    Gek is currently looking at the code of this tool. I hope he will find some time to do a proper fix to it.


    _________________
     
    avatar
    Leonardo Ratafia
    Driver
    Driver

    Posts : 244
    Join date : 2010-04-18
    Age : 39
    Location : Montevideo - Uruguay

    Re: NK server tool not working after update?

    Post by Leonardo Ratafia on Wed Oct 24, 2012 4:42 pm

    hi, any news on the nk server tool?
    avatar
    Andrea Lojelo
    ---
    ---

    Posts : 12576
    Join date : 2009-04-26
    Age : 38
    Location : Den Haag

    Re: NK server tool not working after update?

    Post by Andrea Lojelo on Wed Oct 24, 2012 11:57 pm

    No time at the moment to work on it, unfortunately. Let's hope that in the next weeks Gek can find some time for it.


    _________________
     
    avatar
    Andrea Lojelo
    ---
    ---

    Posts : 12576
    Join date : 2009-04-26
    Age : 38
    Location : Den Haag

    Re: NK server tool not working after update?

    Post by Andrea Lojelo on Sun Nov 04, 2012 12:51 pm

    Here is the new version of Juha's nK Server Tool.
    I would like to thank Juha for trusting us to do this work, and Gek for spending time on it.


    Release notes:
    v1.0.23 - 03.11.2012
    - version made by Radiator Springs Racing (www.radiators-champ.com), special thanks to Fulvio "Gek" Genova
    - compatible with new version of nKPro (copying required files to the server folder)


    _________________
     
    avatar
    Leonardo Ratafia
    Driver
    Driver

    Posts : 244
    Join date : 2010-04-18
    Age : 39
    Location : Montevideo - Uruguay

    Re: NK server tool not working after update?

    Post by Leonardo Ratafia on Sun Nov 04, 2012 10:02 pm

    it would be nice to clear out that it needs .net framework 4.0 to work
    avatar
    Andrea Lojelo
    ---
    ---

    Posts : 12576
    Join date : 2009-04-26
    Age : 38
    Location : Den Haag

    Re: NK server tool not working after update?

    Post by Andrea Lojelo on Sun Nov 04, 2012 10:54 pm

    why that? nk is using 4.0 as well, if I'm not mistaken.


    _________________
     

    Sponsored content

    Re: NK server tool not working after update?

    Post by Sponsored content


      Current date/time is Sun Jun 25, 2017 6:50 pm